Blocky Blockade experimental Linux version

Reply
Guyk Posts: 169 Registration: 2014-04-15
Feel free to use this post to share your feedback and bugs specific to the Linux game client and dedicated server.

This Linux version has been tested on Ubuntu 15.10 and 16.04.
You will find .sh scripts in the root folder, where you unzip the downloaded archive:
  • start_server.sh enables you to start a dedicated server (like on Windows)
  • StellarOverload.sh enables you to start the game


If you edit StellarOverload.sh with a text editor, you will see 2 command lines that start the game:
  • The first, “./StellarOverload -OpenGL4” is commented and enables you to start the game using OpenGL 4 which gives you access to the shader model 5, resulting in a rendering equivalent to the rendering on Windows using DirectX 11. It is commented by default because, depending on the installed video driver, you could experiment graphical issues when starting the game.
  • The second, “./StellarOverload”, which will be executed by default if you launch StellarOverload.sh, starts the game using OpenGL 3 and is limited to shader model 4. The rendering won’t be as good as the rendering on Windows (darker, like on Mac) but it has more chance to work everywhere.


If you want to try the OpenGL 4 version, you just have to uncomment the “./StellarOverload -OpenGL4” line by removing the # character at the beginning of the line, and comment the next line “./StellarOverload” by inserting a # character at the beginning of the line.

In case of a "Permission denied" error:
  • Go to the folder where you extracted the archive and give the execution permission to all the .sh script files
  • Go to the sub-folder StellarOverloadAlpha/Binaries/Linux and give the execution permission to both StellarOverload and StellarOverloadDedicatedServer


In order to give the execution permission to a file, on Ubuntu in a file explorer, right click the file, choose “Properties” from the pop up menu, then go to the “Permissions” tab and check off “allow executing file as program”.
Alternatively you can execute the command chmod a+x [Filename] from within the file's folder.
#1 2016-06-13
Blubbll Posts: 35 Popularity: 5
gg
#2 2016-06-13
synasius Posts: 2 Registration: 2014-06-03
I've been playing for a few hours with no problems.
The game runs smoothly both OpenGL 3 an 4 versions.

I'm using Ubuntu 16.04 with a GTX 660M and the nvidia proprietary driver 367.18

BTW, thanks a lot for the linux support!!
#3 2016-06-14
Modified by synasius on 2016-06-14.
NeoM Posts: 1191 Registration: 2014-04-04
Nice to hear !
Thanks
#4 2016-06-14
vortex Posts: 17 Registration: 2014-06-15
Thank You So much for linux version..
#5 2016-06-24
vortex Posts: 17 Registration: 2014-06-15
Hi,
Game runs great on linux without any issues..
has anyone tried to host a linux server btw.. I couldnt get that to work
#6 2016-06-28
cyberjasse Registration: 2014-08-03
@vortex I launched a linux server via ssh. Do you need help ?
#7 2016-06-28
vortex Posts: 17 Registration: 2014-06-15
@cyber.. thanks.. I got it working..
I was using a port that was used by another service..
are there any public servers btw for the story mode ?
#8 2016-06-29
Amatai Posts: 5 Registration: 2014-06-02
Merci beaucoup pour le portage, je vais le testé immédiatement.

Thank a lot for the port, I will test it right now.
#9 2016-07-02
liamdawe Posts: 1 Registration: 2016-09-15
Just to confirm that on Ubuntu MATE 16.04 the game works fine.

In both the old OpenGL and OpenGL 4 mode, it launches perfectly.

It doesn't even have issues with me having two monitors, awesome stuff.

Thanks a lot for supporting Linux!
#10 2016-09-15
QUASAR Posts: 2 Registration: 2016-09-15
Nice Game, I just find out about it in gaming on linux web page, thanks for the Linux version, I will be purchasing it tomorrow!!
#11 2016-09-15
ShadowCraft Posts: 3 Registration: 2016-02-04
Have been playing the game on Ubuntu 16.04 and Arch Linux. It runs great and is a lot of fun! Can't wait to see the next build! Thanks devs for supporting Linux!

P.S. Gaming on Linux did a nice write up on your game:
https://www.gamingonlinux.com/articles/stellar-overload-previously-named-planets-has-released-an-experimental-ue4-linux-build-looks-very-cool.8096
#12 2016-09-16
ysblokje Posts: 4 Registration: 2016-09-16
Hi ! Nice that a linux version in being worked on! As a thank you , I bought the game.
I tried running the dedicated server but it crashed.


There are 2 errors on my screen (and a lot of warnings)
- Planets3:Error: LoadUniverse(925) :Could not load character data : no local player controller found.
- Assertion failed: IsInGameThread() [File:E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private\TimerManager.cpp] [Line: 190]

Signal 11 caught.
EngineCrashHandler: Signal=11
[2016.09.16-13.12.38:327][ 47]LogLinux:Error: appError called: Assertion failed: Assertion failed: IsInGameThread() [File:E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private\TimerManager.cpp] [Line: 190]


Starting ../../../engine/binaries/linux/crashreportclient
./start_server.sh: line 17: 7770 Aborted (core dumped) $SERVER_CMD

Hope this helps.
Btw the client runs just fine
#13 2016-09-16
Guyk Posts: 169 Registration: 2014-04-15
@ysblokje: What is your Linux distribution and can you please share your computer’s configuration ?
#14 2016-09-16
ysblokje Posts: 4 Registration: 2016-09-16
@Guyk, I tried it on my physical machine
archlinux 64bit 16Gb (so extremely up-to-date software wise)

And just to see if it was a distro problem, I tried running it on a virtual ubuntu16.04 64bit with 4Gb of memory.

Both ended with that crash.

Also both times the coredumps stored by the system were truncated so I couldnt get a decent backtrace. I'll try to run the server with gdb so I can at least get a decent backtrace for you guys.

Also the dependencies for the server are quite ridiculous, it needs a bunch of X11 related packages to be installed, which for a server really doesn't make much sense. But I can imagine that getting rid of those deps is a low priority thing atm.
#15 2016-09-17
ysblokje Posts: 4 Registration: 2016-09-16
So here's a backtrace from the 16.04 machine (I'll keep using it to prevent a moving target situation)

Assertion failed: IsInGameThread() [File:E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private\TimerManager.cpp] [Line: 190]


Thread 9 "Paralle-sks_1_1" received signal SIGTRAP, Trace/breakpoint trap.
[Switching to Thread 0x7fffe7f11700 (LWP 3132)]
0x00007ffff7bcb2a9 in raise (sig=5) at ../sysdeps/unix/sysv/linux/pt-raise.c:35
35 ../sysdeps/unix/sysv/linux/pt-raise.c: Bestand of map bestaat niet.
(gdb) bt
#0 0x00007ffff7bcb2a9 in raise (sig=5) at ../sysdeps/unix/sysv/linux/pt-raise.c:35
#1 0x0000000003aa378b in FLinuxPlatformMisc::DebugBreak () at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime/Core/Public\Linux/LinuxPlatformMisc.h:35
#2 FTimerManager::InternalClearTimer (this=0x2676c3d31a50, InHandle=...) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/TimerManager.cpp:190
#3 0x00000000035e7537 in FTimerManager::ClearTimer (this=0x2676c3d31a50, InHandle=<error reading variable: Cannot access memory at address 0xc3c>)
at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime/Engine/Public/TimerManager.h:226
#4 AActor::SetLifeSpan (this=0x2676c661c400, InLifespan=<optimized out>) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/Actor.cpp:3937
#5 0x00000000035e2b8e in AActor::BeginPlay (this=0x2676c661c400) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/Actor.cpp:2784
#6 0x00000000035e264e in AActor::PostActorConstruction (this=0x2676c661c400) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/Actor.cpp:2680
#7 0x00000000035e18c7 in AActor::FinishSpawning (this=0x2676c661c400, UserTransform=..., bIsDefaultTransform=true) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/Actor.cpp:2600
#8 0x00000000035e10e7 in AActor::PostSpawnInitialize (this=0x2676c661c400, UserSpawnTransform=..., InOwner=<optimized out>, InInstigator=<optimized out>, bRemoteOwned=<optimized out>, bNoFail=<optimized out>,
bDeferConstruction=<optimized out>) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/Actor.cpp:2558
#9 0x000000000380a21d in UWorld::SpawnActor (this=0x2676ca427000, Class=<optimized out>, UserTransformPtr=<optimized out>, SpawnParameters=...) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/LevelActor.cpp:428
#10 0x000000000380a331 in UWorld::SpawnActor (this=0x2676ca427000, Class=0x2676b8cdd680, Location=<optimized out>, Rotation=<optimized out>, SpawnParameters=...)
at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Engine\Private/LevelActor.cpp:266
#11 0x000000000200c282 in UWorld::SpawnActor<AP3Entity> (this=<optimized out>, Class=<optimized out>, SpawnParameters=<error reading variable: Cannot access memory at address 0xffff>)
at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime/Engine/Classes\Engine/World.h:2841
#12 UP3EntityManager::CreateEntity<AP3Entity> (iClass=0xc3c) at S:/Projects/trunk/Games/Planets3UDK/Source/Planets3UDK/Public/Game/Entity/P3EntityManager.h:97
#13 UUniverseManager::CreateMetablockEntity (this=<optimized out>, arch=..., param=0x0, position=..., orientation=..., factionId=3 '\003')
at S:\Projects\trunk\Games\Planets3UDK\Source\Planets3UDK\Private\VoxelEngine\World/UniverseManager.cpp:1437
#14 0x0000000001e2af1f in DungeonInstance::generateDungeonMetaBlockEntity (this=0x2676bf634b40, iUniverseManager=..., iIndexStorage=..., iArch=..., iParam=<optimized out>, iPosition=..., iOrientation=...)
at S:\Projects\trunk\Games\Planets3UDK\Source\Planets3UDK\Private\VoxelEngine\Generation\Dungeons/DungeonInstance.cpp:1269
#15 0x0000000001ef8bc7 in DungeonUnobtainium::preInit (this=0x2676bf634b40, iRandomizer=...) at S:\Projects\trunk\Games\Planets3UDK\Source\Planets3UDK\Private\VoxelEngine\Generation\Dungeons\Unobtainium/DungeonUnobtainium.cpp:145
#16 0x0000000001e25d9d in DungeonInstance::init (this=0x2676bf634b40) at S:\Projects\trunk\Games\Planets3UDK\Source\Planets3UDK\Private\VoxelEngine\Generation\Dungeons/DungeonInstance.cpp:458
#17 0x0000000001fcb719 in ParallelTasksThread::execute (this=0x2676c10b1000) at S:\Projects\trunk\Games\Planets3UDK\Source\Planets3UDK\Private\VoxelEngine\ParallelTasks/ParallelTasksThread.cpp:60
#18 0x0000000001a0cbe7 in Thread::Run (this=0xc32) at S:\Projects\trunk\Games\Planets3UDK\Source\Planets3UDK\Private\Core\Multithreading/Thread.cpp:26
#19 0x00000000022391bb in FRunnableThreadPThread::Run (this=0x2676cd9e3860) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Core\Private\HAL/PThreadRunnableThread.cpp:26
#20 0x000000000223175f in FRunnableThreadPThread::_ThreadProc (pThis=0x2676cd9e3860) at E:\UDK\CDUnrealEngine_4_10_Wwise\Engine\Source\Runtime\Core\Private\GenericPlatform/../HAL/PThreadRunnableThread.h:167
#21 0x00007ffff7bc16fa in start_thread (arg=0x7fffe7f11700) at pthread_create.c:333
#22 0x00007ffff2bdab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109
#16 2016-09-17
CodingMarmot Posts: 1055 Registration: 2014-04-15
Seeing this log, I think if the game is launching in an old play mode (the cognitron mineshaft) which is no more really supported.
Did you launch the dedicated server with the script provided? And the default values in the script?
#17 2016-09-24
QUASAR Posts: 2 Registration: 2016-09-15
It works like a charm, I hacked the fortress and the wnt to all time night planet, looking forward to new missions, meanwhile I will build something in the first planet.
#18 2016-09-25
ysblokje Posts: 4 Registration: 2016-09-16
Published By CodingMarmot2016-09-24 08:14:59Seeing this log, I think if the game is launching in an old play mode (the cognitron mineshaft) which is no more really supported.
Did you launch the dedicated server with the script provided? And the default values in the script?

Thanks for the suggestion.
I would appear I changed SERVER_UNIVERSE= reset it to the original setting and it started.
Might I suggest a nicer response from the game to misconfiguration or a "don't touch anything!" in the readme.

Now that is seems to be running I'll suggest to Liam of GOL we play it on the friday stream.
#19 2016-09-25
Reply
Close We use cookies to ensure that we give you the best experience on our website.
By continuing to browse the site you are agreeing to our use of cookies. Click here for more information about cookies.

Altalus

Send a friend request to

Send Request Cancel
Close

Do you really want to report this nickname () as abusive?

An error occured...Please retry or contact us to solve the problem

Thank you for accepting the forum terms of use.
You now have access to all the forum features (including creating new topics and messages).

Reply Quote Modify Delete Moderate Report as critical Add to CD bookmarks Remove from CD bookmarks Close topic (Re)open topic Set as post-it Stop setting up as post-it Set as announcement Stop setting up as announcement Jump to first Cubical Drift message Next Cubical Drift message

Do you really want to delete this message (this operation cannot be undone)?
Please note that if your message is the first one of a topic, the topic will be deleted too.

Cancel Submit